CLARIFY Desktop
# Table of Contents

Getting Started........................................................................................................................................... 5  
    Clarify 1 Users: Turning off the Clarify 1 menubar/status menu helper............................... 6  
    How to capture images ....................................................................................................................... 10  
    Importing ScreenSteps 2 content ...................................................................................................... 13  
    How to capture full screen applications on Windows ................................................................. 16  

Working with Steps.................................................................................................................................... 19  
    How to auto-number steps.................................................................................................................. 20  
    Nesting steps (substeps) ..................................................................................................................... 23  
    Changing the format your images are exported in ........................................................................... 25  
    How to embed HTML (or a hosted video) into a step .................................................................... 27  
    Adding anchors to steps in HTML output ....................................................................................... 30  
    Changing the position of the text and image for a step ............................................................... 33  

Working with Images and Annotations................................................................................................. 34  
    How to rotate an image....................................................................................................................... 35  
    Replacing an image............................................................................................................................. 36  
    Automatically scaling images that you capture or add ............................................................... 39  
    How Clarify handles screenshots taken on high-resolution monitors ........................................ 40  
    How to change the start number for a sequence annotation ....................................................... 42  
    How to crop an image .......................................................................................................................... 43  
    How to add multiple images to a step .............................................................................................. 45  
    How to create an annotation preset from an existing annotation .............................................. 48  
    How to update existing annotations using an annotation preset .............................................. 50  
    How to blur information in images .................................................................................................. 52  
    Changing the border that appears around step images ............................................................... 54  
    Aligning and relayering annotations .............................................................................................. 57  
    How do I resize images and the image canvas? ............................................................................. 60  
    How to configure the keyboard shortcut for capturing images ................................................... 64  
    Using the capture helper to capture images ................................................................................... 66  

Working with Text ...................................................................................................................................... 68
How to format text.................................................................................................................................69
How to change the starting number of numeric lists............................................................72
Adding links to text....................................................................................................................................75
Using the Code Formatting feature......................................................................................................79
How to create a numeric list from sequence annotations used in a step..............................82
Can I change the text size of words in the article description or step instructions?........84

Sharing Documents .....................................................................................................................................85
How do I share Clarify documents?........................................................................................................86
Creating a sharing account to quickly export to PDF, Word, HTML, Email, Clarify-it.com, Evernote, or WordPress .........................................................................................................................88
Sharing with WordPress..................................................................................................................................93
Sharing with Dropbox.....................................................................................................................................110
Sharing with Evernote ....................................................................................................................................117
Why does my document need to be saved after exporting to a web sharing account? 124
Using the Clipboard Template feature with Clarify-it and Dropbox sharing accounts ....125
How to break the link between a document and an online account .............................................129
Adding pages to a Github wiki using Markdown export .................................................................132
How to edit your "Sharing" settings ........................................................................................................138
Importing DOCX files into Google Docs ............................................................................................140

Customizing PDF Output.............................................................................................................................142
Creating a Custom PDF Template..............................................................................................................143
Modifying where page breaks are added ............................................................................................148
Variables you can use in PDF Templates.................................................................................................150
Recipes for customizing PDF templates using the Custom CSS tab ..............................................152
How does Clarify size images in PDF output? ....................................................................................158
Importing and Exporting Custom PDF Templates ....................................................................................159

Miscellaneous..................................................................................................................................................162
Installing a custom HTML template ..........................................................................................................163
Customizing the Copy Rich Text to Clipboard template ........................................................................166
Adding tags to your document..................................................................................................................170
Controlling how image ALT tags are generated when exporting to HTML .................................174
Moving Clarify to a different computer .................................................................176

Troubleshooting ........................................................................................................179

Internet Issues ............................................................................................................180

"Previous request not completed" error .................................................................181

Error when trying to capture on Windows: "An error occurred while capturing the screen: process is not open for write" ........................................................................................................182

Why is the screen black when I try to capture the screen on Windows? .................183

Why does Clarify freeze when I try to capture the screen? ......................................184

How do I troubleshoot "error 10013 on socket"? .......................................................185

Issues with posting to a WordPress blog ..................................................................186

Using Clarify with Wordpress.com Two-Step Authentication .................................187

Unable to create a Dropbox or Evernote sharing account .........................................190

System compatibility issues .....................................................................................191

"the document could not be created" error when using Mac App Store version ......193
Getting Started
Clarify 1 Users: Turning off the Clarify 1 menubar/status menu helper

If you use Clarify 1 then you may need to turn off the menubar (OS X) or status menu (Windows) helper. This article will show you what to do before running Clarify 2 so that the Clarify 1 helper application doesn't interfere with Clarify 2.

OS X

Launch Clarify 1 on OS X and do the following:

1. Open Preferences.
2. Uncheck Launch Clarify at Startup and Clarify Status Menu is available after quitting Clarify.

Quit Clarify 1 Helper

From the menubar (1), click on the Clarify icon and select Quit (2).
At this point you can launch Clarify 2 without any interference from Clarify 1. The Clarify 1 helper application will only activate when Clarify 1 is running.

Windows

Launch Clarify 1 on Windows and do the following:

1. Open Preferences.
2. Uncheck **Launch Clarify at Startup** and **Clarify Status Menu is available after quitting Clarify**.
Quit Clarify 1 Helper

From the taskbar (1), right-click on the Clarify icon and select Quit (2).
At this point you can launch Clarify 2 without any interference from Clarify 1. The Clarify 1 helper application will only activate when Clarify 1 is running.
How to capture images

You have three options for capturing images:

- Use the **Capture button**
- Use the **keyboard shortcut**
- Using the **capture helper application**

This article will show how to use the **Capture button**.

Select Capture button

Drag over area to capture and hit return

Drag over the area you want to capture and then press return on your keyboard. The image will be captured.
Changing the delay

If you would like a bit of a delay before the screen capture session begins, you can change the capture delay setting. Click on the number to the right of the camera to specify the number of seconds that Clarify should wait before starting the capture session after you click the capture button.

Changing the delay is helpful if you need to set up a screenshot. For example, if you want to capture a menu.
Capture tricks

• Press the space bar to capture a full window instead of just a region. Press the spacebar again to go back to region capture mode.
• Press R to cycle through the previous regions you have captured. This can be handy when capturing the same area of the screen over and over again.
• Press C to show or hide the cursor in the capture.

Keyboard shortcut

• Mac: cmd-shift-2 (default)
• Windows: ctrl-shift-2 (default)
Importing ScreenSteps 2 content

Clarify can convert ScreenSteps 2 manual and lesson package files into Clarify documents. You can export package files from ScreenSteps 2.

If you are importing a ScreenSteps 2 manual package be aware that Clarify will only convert the lessons in the package file. Clarify doesn't have a concept of manuals or chapters so that information will be discarded.

Converting a manual or lesson package file to Clarify 2 files

You can use the **File > Open** menu to open a ScreenSteps 2 manual package file.
Select the package file

Decide where to store files

If the package you are opening only contains 1 ScreenSteps lesson then that lesson will be opened in a Clarify document.

If the package contains more than 1 ScreenSteps lesson then you will be prompted for a folder to store the converted files in.
After the conversion is complete you can then open the converted documents in Clarify.

The lessons in the ScreenSteps 2 package file were successfully converted to Clarify documents.
How to capture full screen applications on Windows

Using the screenshot hotkey

In order to capture a full screen application you will want to use the screenshot hotkey. You can find out what the hotkey is in General preferences. The default is Control + Shift + 2.

Starting the capture

While viewing the full screen application, press the screenshot hotkey combination. You won't see anything happen, but that is to be expected.

Now move the mouse to the top-left corner of the screen and switch back to your desktop.
The screen capture tools appear

When you switch back to the Desktop the Clarify capture tools will appear and you can capture your full screen application.
Here is a screenshot taken from the Weather application in Windows 8.
Working with Steps
How to auto-number steps

Open Document Inspector and select Auto-number Steps

1. Open the Document Inspector
2. Select Auto-number Steps

All of the steps will automatically be numbered.

Exclude steps from being numbered

If you want to prevent a step from being numbered:

1. Open the Step Inspector
2. Select Exclude from Auto-number
3. The number prefix for that step will be removed
Only auto-number sub-steps

There may be situations where you don't want to auto-number the top level steps, but just the sub-steps. To do that:

1. Open the **Steps Inspector**
2. Select **Auto-number sub-steps**
3. The sub-steps for that step will be numbered
Nesting steps (substeps)

Clarify has the ability to create substeps. A substep is indented under the parent step and can be one level deep. A substep title will appear differently when you export the document.

Select the step that you would like to make a substep
Move the step right using the Document > Move Step menu

The step is now a substep. If you want to make the substep a step again just select the Document > Move Step > Left menu option.
Changing the format your images are exported in

By default Clarify will export images in PNG format. But there may be occasions when you want Clarify to export to JPG instead (for example if you are working with photos instead of screenshots).

Select Steps

Select the steps you want to edit. You use the shift or the cmd (Mac)/ctrl (Windows) key to select multiple steps.
Select the Step Inspector

Set the export format
How to embed HTML (or a hosted video) into a step

By following these instructions you can embed HTML into a step. Use this technique to embed videos hosted on video services into your articles.

Change step media type to HTML

With a step selected (1), click on the step inspector (2) and change the Media Type to HTML (3).

Enter HTML

Note: If you are trying to add a video from YouTube, make sure to use the embed code.
Preview

If you would like to preview what the HTML will look like, click on Preview.

Add an image representation

Some export formats can't display the HTML for a step. You can click on the Image tab and add an image that will be used for these export formats.
The image will always be used when exporting to Word. The image will be used for HTML that isn't supported by PDF (e.g. iframes and embedded video).
Adding anchors to steps in HTML output

You can add anchor tags to steps that will be assigned as the "id" property in HTML output. This can be useful for linking directly to specific steps when you share a Clarify document to the web.

For example, if you set the anchor name for a step to "special-step" and your Clarify document was exported and available at the following URL:

http://www.myblog.com/my-clarify-article.html

then you could link directly to the step by adding #special-step to the URL:

http://www.myblog.com/my-clarify-article.html#special-step

**Note:** If you don't specifically set an anchor for a step then Clarify will generate one automatically based on an internal id that Clarify assigns to steps when you create them. This anchor will remain the same each time you export the Clarify document.

Select Step

Select the step you want to edit.
Open Step Inspector and set the Anchor Name

When setting an anchor name here are some tips:

• The first character needs to be a letter.
• Only use letters, numbers, hyphens, or underscores.

Linking to the step from within Clarify

If you would like to link to a step with an anchor name from within Clarify, just prefix the anchor name with the # character in the URL dialog. For example:

#step-1
The text **my link** will link to:

```
#step-1
```

- Open link in new window

[OK] [Cancel]
Changing the position of the text and image for a step

Each step in Clarify has a place for text and another for media (images). This article shows you how to specify which one appears right after the step title.

Set the Media Position

With the step selected, open the step inspector (1) and change the Media Position setting (2). This setting specifies whether the media section appears above the text section or below the text section.
Working with Images and Annotations
How to rotate an image

Select Edit > Rotate Image
Replacing an image

You have 3 options for replacing an image:
1. Right click on the image and select replace image
2. Click the Replace Image icon in the step
3. Click the replace image icon at the top

1. Right click on the image

If you right click on the image you'd like to replace, you will have a few options:

- Replace the image with a clipboard image
- Replace the image with a screencapture (Clarify will pull up the cross hairs and allow you to take a screenshot)
- Replace the image with a file you have already saved

2. Click on the Replace Image icon in the step

Below each image in Clarify there is an icon you can click to replace an image.
3. Click on the Replace Image icon at the top

Select the image you'd like to replace and then click the replace image icon in the top left corner.
Automatically scaling images that you capture or add

Sometimes you may want to automatically scale images as you capture them to a document. Scaling images will reduce the size of images that are too tall or too wide. Scaling will not affect images that are smaller than your max height or width.

Select Auto Scale from the document inspector

You can set either a max height, width or both.
How Clarify handles screenshots taken on high-resolution monitors

This article explains how Clarify handles screenshots taken on high-resolution displays. Clarify considers an image to be high-resolution if captured on a Mac retina display or on a Windows computer that has the zoom set higher than 100%.

Overview

When Clarify captures an image on a high-resolution monitor it stores all of the available image data. For example, on a Mac retina display there is 4x as much data in a screenshot of a 300x300 square as there is on a traditional monitor. Clarify is basically capturing a 600x600 image but displaying it in a 300x300 area. The same goes for a Windows computer with the zoom set to 200%.

When Clarify exports these images the high-resolution version of the image is used in most cases.

How Clarify embeds image density (ppi) information in the images it exports

The PNG or JPEG files that Clarify exports will include the density information in the file metadata. The image density setting will use a base value * the scale of the image. The base value is usually determined by the operating system that Clarify is running on.

On OS X the base value is 72ppi. On Windows, the base value is 96ppi.

For example, for a screenshot taken on a Mac retina display (which uses a base ppi value of 72) the density metadata value would be set to 144ppi. This is because a retina display displays 2x more data than a normal display. A Windows installation (which uses a base ppi value of 96) with the zoom set to 150% would have the density metadata value set to 144ppi.

Note that this ppi information that is embedded in the file DOES NOT affect how much data is in the actual image. It merely tells an application that is opening the image file how to scale the image. Note that web browsers completely ignore the density information in the image file.
Exporting to HTML

The default behavior when exporting to HTML is to export all of the image data but display the image at the natural size. For the 300x300 example, a 600x600 image would be exported but the HTML would set the width and height of the image to 300x300. This way, your images will look crisp on other high-resolution monitors.

An HTML template can override this behavior by setting the `hi_res_images` property to `false`. When set to false, Clarify will export images at their natural size and will discard the high-resolution data. This will result in smaller image files that won't look as crisp on high-resolution monitors.

Exporting to PDF/Word

When Clarify exports images for PDF and Word export the high-resolution version of the image is used. Images exported for PDF output use a base value of 96 which is what the PDF exporter expects. This occurs on Mac as well as Windows.

Images exported for Word output will use the base value for the platform you are running Clarify on. 72ppi for Mac, 96ppi for Windows.
How to change the start number for a sequence annotation

Select sequence annotation and set start number

1. Add a sequence annotation to your image
2. Select the annotation
3. Set the start number in the annotation settings
How to crop an image

Select Edit > Crop Image

1. Select the image
2. Select Edit > Crop Image

Draw crop area

Click and drag over the area you want to keep.
Press return

Press return and the image will be cropped.
How to add multiple images to a step

Clarify supports multiple images in each step. When adding multiple images to a step the images become part of a single canvas that you can draw on and resize. When the document is exported, the entire canvas will be exported as a single image.

Adding a new screenshot

Click the "Add image" button

You will be able to capture an image just as you normally would in Clarify.

The image will be added below the current image. The image selector tool will be activated and you can then reposition the image and/or add a drop shadow.
Here is an example of the previous step after repositioning the images and adding drop shadows.
Adding images on the clipboard or from files

Right-click in step image area

In the contextual menu for a step image you will find the Add Image Using menu option. If an image is on the clipboard then you can select Clipboard Image. You also have the option to take a new screencapture or insert an existing Image File...
How to create an annotation preset from an existing annotation

Select Preset and then Select Create Preset from Annotation menu

Name it
Preset will appear in the menu
How to update existing annotations using an annotation preset

Before you can do this you must have stored an annotation preset.

Select Annotation > Apply preset to all annotations

Right click on the annotation type you want to update. Select Apply preset to all annotations.
Setting will be applied to all annotations

All of my arrow annotations are updated to have the red background.
How to blur information in images

Sometimes you need to blur out sensitive information in your screenshots. The blur tool can help you.

**Important:** The blur tool is a non-destructive annotation. That means that any author that has permission to edit an article can remove the blur annotation and would be able to see the underlying information. But the blur is merged down for display in your knowledge base, so non-authors will not be able to remove it.

Select blur tool

![Image showing how to select the blur tool](image)

Drag over area to blur

1. Drag over the area to blur.
2. You can modify the amount and spread of the blur by adjusting the sliders.
Changing the border that appears around step images

You can adjust the border that is applied to images when they are exported. The options are:

- None
- Line
- Picture Frame
- Rounded Corners

Select Steps

Select the steps you want to edit. You can use the shift or the cmd (Mac)/ctrl (Windows) key to select multiple steps.
Select the Step Inspector

Select Image Border

For Line: Adjust color and width

If you select **Line** you can adjust the width and color of the line using the inspector.
Aligning and relayering annotations

The annotation contextual menu gives you the option of aligning or relayering your annotations.

Aligning annotations

Select the annotations you would like to align and then right-click on one of them. From the Align submenu, select how you would like to align the annotations.

The annotations will then be aligned.
Relayering annotations

To change the layering order of an annotation right-click on it and select an option from the Order submenu.
The annotation layer will then be changed. In this example I moved the sequence annotation in front of the highlight annotation.
How do I resize images and the image canvas?

Canvas resize handles

Clarify has 4 handles around the sides of the step image editor that will resize the canvas. Clicking on any of these handles will allow you to change the size of the canvas where images and annotations can be placed. You cannot make the canvas smaller than an image (e.g. you cannot crop an image using the canvas handles).

Resizing an image with the image resize handle

If your step has a single image then an image resize handle will appear in the bottom-right corner when the step is selected. Clicking on this handle will allow you to resize the image. Hold down the Option (OS X) / Alt (Windows) key while resizing to resize in 10% increments.
Resizing an image with the image tool

You can also use the image tool to resize images. With the image tool selected (1), you can click on an image and handles will appear around the image (2). You can click on the handles to resize the image.
Resizing an image using the contextual menu

If you want more precise control over the image size then you can use the image contextual menu. If the step only has a single image then you can right-click on the step image and select **Resize Image**.

If your step has multiple images then you must select the image tool and then right-click on an image and select **Resize Image**.
After selecting **Resize Image...** a dialog will appear that gives you precise control over the size of the image.
How to configure the keyboard shortcut for capturing images

Open preferences

- On Mac: **Clarify > Preferences**
- On Windows: **Edit > Preferences**

Configure the hot key

To configure the hotkey, click inside the field of the action you want to configure and type the key combination you want to use.
Using the capture helper to capture images

When Clarify is running, the capture helper application will appear in the menu bar on OS X or in the system tray on Windows. You can use the capture helper to change the capture delay and perform image captures.

OS X

On OS X you will find the Clarify capture helper application in the menu bar.

Windows

On Windows the Clarify capture helper is in the system tray. Right-click on the Clarify icon to display the menu of options.
Working with Text
How to format text

Clarify offers quite a few options for formatting your text.

Click on the paragraph field and select format options

The format bar appears when you select the paragraph field. Click one of the icons to change the format of your text.

How Clarify adds spacing between paragraphs

When you press the return key while editing text in Clarify a new paragraph will be created. Clarify adds spacing between each paragraph like you will see in text on a website.
The exception to this is text that is formatted as **code** which has no spacing between each line.

If you would like to start a new line within a paragraph you can press **OPTION + RETURN** on Mac or **CONTROL + ENTER** on Windows (The Enter key that is above the Shift key).
### 1. Click on Posts

<table>
<thead>
<tr>
<th>Paragraph 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paragraph 2</td>
</tr>
<tr>
<td>Code line 1</td>
</tr>
<tr>
<td>Code line 2</td>
</tr>
<tr>
<td>Paragraph 1</td>
</tr>
<tr>
<td>New line but still part of paragraph 1</td>
</tr>
</tbody>
</table>

**No spacing**
How to change the starting number of numeric lists

Sometimes you will want to continue a numeric list from one step to the next. You can start a numeric list on whichever number you'd like.

Select the bulleted list

Select the list you'd like to change.

Click the Start Numeric List At...

Click Format > List > Start Numeric List At...
Change the number the list starts at and click OK

The list will begin on the designated number

As you can see, the list now begins at 4.
Changing your LinkedIn Profile

Click on Edit Profile

To edit your profile, click:

4. Profile
5. Edit Profile
Adding links to text

Select text and edit hyperlink

After selecting the text you would like to add a link to, use the Format > Edit Hyperlink menu option (1) or click on the link button (2) in the formatting toolbar.

Enter the URL

Enter the URL of the file you would like to link to. If you would like the link to open in a new browser window when the user clicks on it then check the Open link in new window checkbox.
Preview a link

To quickly see the URL that hyperlinked text links to, hold your mouse over the text and the link will appear.

To open the link in your web browser click on the link while holding down the OPTION key on OS X or the ALT key on Windows.

Triggering an email

If you want a link to open the default email client when clicked on, prefix the email address you want the email sent to with the text mailto:. Here is an example:

mailto:info@clarify-it.com
Linking to files on a local network

The URL dialog will help you create links to files on your local network as well. If you will be distributing the final document to co-workers then you may want to link to other files on the network.

A link to a file on a local network ultimately needs to use the file: protocol. For example, to link to `\vmware-host\Shared Folders` on your network you would format the URL like this:

```
file://vmware-host/Shared%20Folders
```

Clarify will auto-generate the proper URL for you if it can find the file or folder you enter in the URL dialog. You can paste the normal path into the URL dialog as shown below and then click OK.
Clarify will automatically reformat the path to the file or folder as a file:// URL for you. You can verify this by mousing over the link.
Using the Code Formatting feature

This article shows you how the code formatting option works. Clarify allows you to format code in your instructions as entire blocks of code or as individual words within a sentence. When you click the code formatting button, what happens to the text depends on what you have selected.

Highlighting words as code

If you just want to mark a word or two as code then select the word(s) and click the code formatting button.

The selected words will be treated as code and formatted accordingly.

In any HTML output that Clarify generates, the text will be enclosed in `<code>` tags.
Marking code blocks

If you want to highlight a block of text as code you can do so as well. If you have no text selected, multiple lines selected, or an entire line selected then the entire paragraph will be converted to a code block.

1. Make your selection.
2. Click the code formatting button.
The selected text is converted to a code block. Any HTML output created by Clarify will wrap the text in `<pre><code>...</code></pre>` tags.

```html
A code demonstration

If you want a code token to stand out in your instructions you can.

```html
<style>
#Content
{
  font-family: Helvetica;
}
</style>

```
How to create a numeric list from sequence annotations used in a step

If you use the number sequence tool on your images, you can use this feature to create a list for you in the paragraph field.

Select the step you'd like to add the list to

In this step, I marked up the image with the sequence annotation.
Select Create List From Sequence

A list is created

The paragraph field is populated with a numbered list that I can edit.
Can I change the text size of words in the article description or step instructions?

Clarify does not provide a way to independently change the size of words within the article description or step instructions. The size of the text as a whole is determined by the format you are exporting to. For example, the PDF template determines the size of the text when exporting to PDF. The CSS on a WordPress site determines the size of text when you export to WordPress and so on.

You can, however, change the overall size of the text in the Clarify document editor.

Changing the size in the editor

From the General preferences pane you can choose the relative size of text in the document editor. Note that this will not change the size of text when you export, just while editing.
Sharing Documents
How do I share Clarify documents?

Clarify offers a number of different ways to share the documents you create with others.

1. Using the File > Export menu

From the File > Export menu you can export your document as to PDF, Word, or HTML. Just select the template you would like to use from one of the menus.

2. Create a sharing account

Clarify also allows you to create sharing accounts. A sharing account allows you to choose the export target and specify additional export options. For example, a sharing account can export to

- Clarify-it.com
- WordPress
- Dropbox
- Evernote

Clarify can also export to

- PDF
- Word
• HTML

For PDF, Word, and HTML sharing accounts, you can specify which template to use so you don't have to select one each time. You can also do things like select a logo to include and specify the text to put in the footer.

To learn about creating a sharing account please see the article [Creating a sharing account](#).
Creating a sharing account to quickly export to PDF, Word, HTML, Email, Clarify-it.com, Evernote, or WordPress

Clarify allows you to share your document in several different formats. First, you'll need to create a sharing account.

A sharing account can be customized to export a document in any of the available export formats (e.g. PDF, Word, Clarify-it.com, WordPress, etc.). You can quickly choose one of your sharing accounts by accessing it from the toolbar across the top of the Clarify document editor.

If you are creating a PDF, HTML, Word, or Email sharing account then you will be able to specify a specific template to use when exporting with that sharing account.

Open Clarify Preferences

[Image of Clarify Preferences menu]
Creating a share account

1. Go to the **Share** preference pane
2. Click the + button.

Select format

From the menu that appears, select the output format for the sharing account.
Configure the sharing account

Each format will have a different configuration screen. The PDF example below allows you to select the PDF template to use, specify an action such as export to a file or export to a temporary file, select a logo for the header, and enter text that will appear in the footer.

The settings you select will be used whenever you click on this sharing account in the Clarify toolbar.
Authorizing with 3rd party services

Note that some export formats require that you authorize Clarify to work with the service. For example, Evernote will display a dialog similar to the one pictured here. Just click on the Authorize button and you will be taken to the 3rd party website where you will authorize Clarify.

![Authorize dialog](image)
The result

When you add a sharing account to the Share tab, an icon will appear in the toolbar of the document editor. Click on the icon to export using the options you have configured.
Sharing with WordPress

This article will show you how to connect Clarify to your WordPress blog as well as how to upload a document.

💡 We recommend using the WP REST API WordPress plugin.

The number one cause of support issues with Clarify center around issues uploading to WordPress using the legacy xmlrpc.php interface that comes with WordPress. Historically there have been security issues with WordPress and xmlrpc interface so many web hosting providers will shut down access to it if the server detects too many requests coming from a particular IP address.

Using the WordPress REST API (recommended but requires WordPress 4.7 or higher)

💡 Using this feature requires Clarify 2.0.7 or above and WordPress 4.7 or above.

You should be comfortable with installing and configuring plugins for WordPress.

Download the necessary plugins

You will need to download and install two plugins:

1. **WP API Categories+Tags**

This plugin adds support for assigning tag to a post using a string rather than tag ids. From the Plugins page of your WordPress admin area, search for **WP API Categories+Tags**.

Alternatively you can locate the plugin at [https://wordpress.org/plugins/wp-api-categoriestags/](https://wordpress.org/plugins/wp-api-categoriestags/).
2. WordPress REST API - OAuth 1.0a Server

From the Plugins page of your WordPress admin area, search for WordPress REST API - OAuth 1.0a Server.

Alternatively you can locate the plugin at https://wordpress.org/plugins/rest-api-oauth1/.
Configure the WordPress REST API - OAuth 1.0a Server plugin

The only plugin that requires configuration is the OAuth plugin. In the Users menu you will find a new Applications option. Click on it.
Click on Add New

Configure Clarify

Fill in the Consumer Name and Description however you would like. For the Callback, enter the following:

http://127.0.0.1:9998/clarify.app/OAuthLibrary

Click Add Consumer when you are done.
Take note of OAuth Credentials for later

After you click Add Consumer will be taken to a screen that shows the OAuth Credentials for the application you just configured. You will need the Client Key and Client Secret when you connect from Clarify to WordPress.
Connect Clarify to WordPress

Open Clarify Preferences

Add a WordPress sharing account

From the Share tab click the + button and select WordPress.
Enter your blog URL

Enter the URL to your blog and click Configure.
Enter your key and secret

When you see the following dialog appear enter the **Client Key** and **Client Secret** from WordPress and then click **Authorize**.

![Wordpress Authorization dialog](image)

**Authorize**

Next you are taken to your WordPress site in the default web browser. Click the **Authorize** button to allow Clarify to access your WordPress site in order to upload posts.
After clicking **Authorize** the WordPress sharing account will be added to Clarify. You can now upload content from Clarify to WordPress.

Clarify ships with one WordPress HTML template that is used when formatting your Clarify document for upload to WordPress. The template does not apply any sort of styling to the content that is uploaded. If you would like to create a custom HTML template that can be used when uploading to WordPress then please refer to the [HTML templates manual](#).
WORDPRESS ACCOUNT

Account Settings

Name: My Blog
Blog URL: http://someblog.com/

HTML Template: Neutral

Test Connection
Using the default xmlrpc.php WordPress URL (not recommended)

Open Clarify Preferences

Add a WordPress sharing account

From the Share tab click the + button and select WordPress.
Enter your blog URL

Enter the URL to your blog and click **Configure**.
Enter your blog login credentials

1. Enter your username and password.
2. Clarify ships with one WordPress HTML template that is used when formatting your Clarify document for upload to WordPress. The template does not apply any sort of styling to the content that is uploaded. If you would like to create a custom HTML template that can be used when uploading to WordPress then please refer to the HTML templates manual.
3. Test the connection to make sure you have entered your information correctly.

Uploading to WordPress

Now that you have configured your WordPress sharing account you will see a WordPress icon in the sharing toolbar. Click on it to upload your document to WordPress.
The WordPress upload dialog

You will see this dialog when you upload the document. You can choose the blog, post type, status, and category (if applicable to the selected post type). Any tags you have assigned to the article will be assigned to the post you create in WordPress as well.
Clarify will list all of the available post types in your blog. The default choices allow you to create a Post or a Page. If you have any custom post types they will show up in the menu as well.

After you make your selections click the **Upload** button. When the upload is complete the URL to the WordPress page will be on the clipboard.

**A note about updating images**

The next time you upload the Clarify document to WordPress Clarify will replace the existing post. When updating an existing WordPress post Clarify tries to optimize the update process by not uploading images which have already been uploaded. If a step image has been uploaded before then it will not be uploaded again if:

1. The image still exists in WordPress and
2. The image content has not changed.
If the image needs to be updated the behavior is different depending on whether you are using the xmlrpc.php url or the WP REST API plugining.

When using the WP REST API plugin the existing image on WordPress will be deleted from WordPress and a new image will be uploaded.

When using the xmlrpc.php url the exiting image on WordPress will be updated with the new image.

A couple of things to keep in mind. You should not modify any images that Clarify uploaded within WordPress itself if you plan on using Clarify to update the post later on. If you use a 3rd party WordPress plugin to replace an image in WordPress, Clarify won't know that you did and will not upload the latest image from the Clarify document. In addition, if you use WordPress to edit the image Clarify will not know that you made changes to it.

**Troubleshooting**

**Issues with posting to a WordPress Blog**

This article provides troubleshooting tips for known issues with posting to WordPress.

Note that these problems are all related to security issues associated with the xmlrpc.php file that ships with WordPress. We are currently working on a solution that uses a new JSON API for WordPress. It requires installing some plugins but so far in our tests does not experience any of the same issues. If you are having trouble posting to WordPress and would like to try the new solution we are working on then send an email to support@screensteps.com.

**Error 403 Forbidden**

If you have iThemes Security installed make sure you don't have it set to deny all xmlrpc.php files. Switch it to only deny pingbacks and try again.

"Unable to reach the Wordpress server", message about your IP address being banned, or a mod_sec.html error

Some web host providers will blacklist an IP address that makes multiple requests to the xmlrpc.php file in a WordPress installation. This is due to the fact that the file has historically been used for nefarious purposes. Since Clarify documents often contain multiple images it is making multiple requests to the xmlrpc.php file on your server and your web hosting service may flag you.

You can contact your hosting provider and ask them to whitelist you so that you can upload to WordPress.
Another potential cause of the "Unable to reach the WordPress server" error could be a WordPress plugin. At least one user has reported issues with using the "EWWW Image Optimizer" plugin. You can try disabling plugins to see if one is causing a problem.
Sharing with Dropbox

Clarify provided Dropbox support through the use of a Public App Folder permission in the Dropbox API. On September 1, 2017 Dropbox removed support for public folders. As of Clarify 2.0.7 Dropbox support has been removed. If you would like to export content to your Dropbox folder you can export using the HTML option and select a folder in the Dropbox folder on your computer.

Clarify can share your documents with others via your Dropbox account. This article will show you how to configure and use a Dropbox sharing account.

IMPORTANT: Clarify uses the Public App Folder permission when sending content to your Dropbox account using the Dropbox API. If you are a Dropbox for Business user and your team administrator has turned off public folders then Clarify will not work.

Open Clarify Preferences
Create a Dropbox sharing account

Click the + button to add a new account.

Authorize Clarify

You will be prompted to visit the Dropbox.com website in order to authorize Clarify to access your Dropbox account. Click the Authorize button to begin.
From the Dropbox.com website, click the **Allow** button.

Once you see the following screen you can close the browser window.
Troubleshooting

Unable to create a Dropbox or Evernote sharing account

If, after clicking the Allow button on the Dropbox or Evernote site, Clarify does not create the sharing account it may be because another application is listening on the same PORT on your computer (currently Clarify uses port 9999).

We have had one report of Clarify not being able to finish creating an account if Extensis Portfolio is running. If you quit Extensis Portfolio you should be able to create the sharing account. After you have created the sharing account you can run Extensis Portfolio and Clarify together without any issues.

The result

If you switch back to Clarify your will see that a new Dropbox sharing account has been configured.
Share on Dropbox

You will now see a Dropbox icon in the Sharing toolbar. Click on it to share a document on Dropbox.
After the document has finished uploading, the URL to the HTML page on Dropbox will be on the system clipboard. You can click the **Visit** button to view the page in your web browser.

The web page

Here is an example of what the web page looks like on Dropbox.
Configuring a clipboard template to use with Dropbox

If you are interested in sharing the Dropbox document in web forums or other sites then learn how to configure a clipboard template for Dropbox.
Sharing with Evernote

Clarify can export your documents to Evernote. The Evernote integration is unique amongst other services that Clarify exports to in that the Clarify source file will be stored with the note that is created in Evernote. This allows you or your team to modify the note from within Clarify at a later date without having to search for the source file.

Open Clarify Preferences

Create a sharing account

From the Share tab, click on the + button and select Evernote.
Authorize Clarify to access Evernote

In order for Clarify to add content to your Evernote account you must give permission. Click the Authorize button to start the authorization process with Evernote.

After logging into Evernote you will be presented with this screen. Click the Authorize button to give Clarify permission to create content in your Evernote account.
You should then see this screen in your browser window if Clarify was able to successfully authorize with Evernote.

Clarify has processed the authorization request. You can close this window.
Troubleshooting

Account added

You will now have an Evernote sharing account in Clarify.

Exporting to Evernote

An Evernote icon will now appear in the Share toolbar in your Clarify documents. When you are ready to export a document to Evernote, click on it.
Select a notebook

In the Evernote export dialog you can specify the name of the note as well as which notebook to store the note in. You will see both personal and business notebooks listed and you can create the note in either type.

Once you have selected a notebook click the **Save** button. Clarify will create the note in Evernote and attach the Clarify source document to the end of the note.

**Note:** If you export the Clarify document to Evernote again you will have the option of moving the note to a different notebook. You will not be able to move a note from a business notebook to a personal notebook or vice versa.
The Clarify source document

You will see this message after the upload is finished. Clarify will store the Clarify source document at the end of the Evernote note. This means anyone with access to the note can update the note using the Clarify source file at a later date.

The note in Evernote

If you sync your Evernote desktop client you will see your note appear. Any tags you assigned to your Clarify document will be assigned as a tag in Evernote.
Editing the note

To edit the note, right-click on the source file and select **Open With > Clarify**.
Why does my document need to be saved after exporting to a web sharing account?

When you upload a Clarify document to a web account such as Clarify-it.com, Dropbox, or WordPress the Clarify document will be marked as dirty and will need to be saved. Each time you upload a Clarify document, information is stored in the Clarify document about the link between the document and the server you uploaded it to. When the link information is stored in the document you need to save the changes in order to store them in the Clarify file on disk.
Using the Clipboard Template feature with Clarify-it and Dropbox sharing accounts

When you share a Clarify document via a web service such as Clarify-it.com or Dropbox, Clarify can place the resulting document content on the clipboard with references to the images hosted on the web service. This makes it easy to share Clarify documents in web forums, help sites, or anywhere else you can post HTML, BBCode and Markdown.

Configure your Sharing account

Create a Sharing account that exports to the web. In this example I am configuring a Clarify-it.com account. I could also use a Dropbox account.

Select a Clipboard Template

From the Clipboard Template menu, select the format you would like the document converted to after it is uploaded.
Share your document

Click on the Share icon in the toolbar to share your document.

In the resulting dialog, click the Copy Markdown button (the actual title of the button depends on the format you chose). This will use the clipboard template you selected to convert the document and add the image references.
The Result

Since I selected the Markdown template, this is an example of what would be placed on the system clipboard for a document with a single step.

```markdown
# A Test
## This is a test step

Some instructions for you to read.

![This is a test step](http://media.screensteps.me/myaccount/f9aq3d/this-is-a-test-step.png?1386972226)
```

Using the Notification Center

You can also copy the clipboard template text to the clipboard using the Notification Center. Click on the **Copy Markdown** link [1] to copy the default template or click on the arrow [2] to display a list of all of the available templates.
Using the Document Inspector

If you want to copy the document to the clipboard using a different template, you can do so from the document inspector. Just click on the clipboard template button in the list of Shared Locations.
How to break the link between a document and an online account

When you upload a document to a shared location Clarify remembers the URL. If you upload the document again then the same URL will be updated with the new document content. This article will show you how to break the connection between a Clarify document and a shared location. This is useful if you need to upload a document to a different URL.

Open Document Properties

Click on the **Document Properties** button (1) in the toolbar. This will show a list of **Shared Locations** (2).
Break Link

Click on the delete icon next to the shared location (1). A dialog will appear asking you to confirm that you want to break the link. Click **Break Link** to proceed (2).
The Link is Removed

The document will no longer be linked to the shared location. The next time you upload the document it will be located at a new url.
Adding pages to a Github wiki using Markdown export

Github repositories come with a wiki that you can use to document your projects. This article will show you how to export Clarify documents to your Github wiki in Markdown format.

If you haven't already cloned your Github wiki to your computer then you will need to do that first.

Clone your wiki on your computer

1. Click on the Wiki link in the sidebar of your repository

2. Create the first page if need be

If you don't have any content in your wiki yet then you will be prompted to create the first page.
Click the **Create the first page** button...

and then save it.

---

### 3. Get wiki git URL

You can now grab the URL to clone the wiki on your computer.
Export your Clarify document using the Markdown HTML template

The HTML exporter in Clarify includes a Markdown template. You can use File > Export > HTML menu (1) or you can create a sharing account that uses the Markdown template (2).
Save to your local wiki directory

Save the .md file to the wiki folder you cloned on your computer.
The result

Clarify will generate an .md file containing your document. The images will be stored in a folder named after the document that is stored in an images folder.

You can export multiple documents to the wiki folder and a new document image folder will be added to the existing images folder.

Commit and push the changes

Add the files to the repository, commit, and push the changes to Github.
The page appears in the wiki

The document you exported will now appear as a page on the wiki!

Using SourceTree to monitor progress on LiveCode

When LiveCode became open source after the Kickstarter campaign all of the source code was moved to Github. Because the livecode repository on Github is public, you can monitor all changes which are submitted to it. I’m going to show you how to easily monitor progress on the LiveCode engine using SourceTree, a free Git client for Mac and Windows made by Atlassian.

Download and set up SourceTree

Visit http://www.sourcetreeapp.com and download the desktop client for Sourcetree. After you finishing installing, continue on to the next step.

1. Agree to the license agreement

Check the necessary checkbox and click Continue.
How to edit your "Sharing" settings

Open preferences

- On Mac: Clarify > Preferences
- On Windows: Edit > Preferences

Edit settings

- Select Share
- Select the account you want to edit from the sidebar
- Edit your settings
Importing DOCX files into Google Docs

Google Docs can import the DOCX files that Clarify exports. This article will show you how to import a DOCX file into Google Docs.

From within a Google Doc document, select File > Open

Switch to the Upload tab and select the DOCX file

1. Switch to the Upload tab.
2. Drag the DOCX file you exported from Clarify onto the drop area in the Upload tab.
The file is imported

The DOCX file created by Clarify will be imported, including all of the images.
Customizing PDF Output
Creating a Custom PDF Template

This article describes how to create a custom PDF template that allows for some common customizations.

If you have very specific needs then please have someone with HTML and CSS knowledge refer to our manual on making custom PDF modifications by hand.

Open preferences

- On Mac: Clarify > Preferences
- On Windows: Edit > Preferences

Create a custom template

Click on the + button to create a new custom template.
Configure the General settings

From the **General** tab you can customize things such as the page size, orientation, image alignment, content flow, header, and footer.

For a list of variables that you can use in the Header and Footer text refer to [this article](#).

Whenever you want to see how your template will look, click the **Preview** button.
Configure the Fonts & Colors

You can specify the font, color and size of text in the PDF document from the Fonts & Colors tab. If a font isn't set for a particular object, the Default Font will be used.
The **Customize CSS** tab enables you to make adjustments to elements that aren't available in the user interface. Refer to the article on [custom CSS recipes](#) for some examples.
Custom CSS

Adds custom CSS to modify the look of the PDF template...
Modifying where page breaks are added

When generating a PDF document Clarify will add page breaks in certain locations. By default, Clarify tries to keep step content together. The other options that you can configure are as follows:

- One step per page: Clarify will add a page break after each step.
- Fit as much content as possible per page: Clarify will put as much content on the page as it can.

If you want to further control over page breaks then it can be done using CSS. You can refer to our article on Recipes for customizing PDF templates using the Custom CSS tab.

Changing the setting for a custom template

You can change the page break settings for a custom template in the General tab using the Content Flow menu.
Changing the setting for sharing accounts

For PDF sharing accounts that use a built-in Clarify template you can change the setting in the **Content Flow** menu.
Variables you can use in PDF Templates

There are a few variables you can use in custom PDF templates.

Header, Footer, Title Page Header and Title Page Footer Fields

[[Document_Title]] - The name of the document.

[[File_Name]] - The name of the PDF file.

[[Date]] - The date in the format that your system is configured to use.

[[Date_Time]] - The date and time in the format your system is configured to use.

[[YYYY-MM-DD]] - Year, month and date.

[[YYYY-MM-DD HH:MM:SS]] - Year, month, date, hours, minutes and seconds. 24-hour clock.

[[YYYY-MM-DD HH:MM:SS 12HR]] - Year, month date, hours, minutes and seconds. 12-hour clock with AM/PM.

[[MM/DD/YYYY HH:MM:SS 12HR]] - Year, month date, hours, minutes and seconds. 12-hour clock with AM/PM.

[[MM/DD/YYYY]] - Month, day and year.

[[DD/MM/YYYY]] - Day, month and year.

[[YYYY]] - Year
Footer Numbering Field

[[Page_Number]] - The page number.
[[Page_Count]] - The total number of pages.
Recipes for customizing PDF templates using the Custom CSS tab

PDF templates in Clarify are written in HTML and CSS. Custom templates allow you to customize the template using CSS. Doing so allows you to customize properties in the PDF output that aren't directly accessible through the custom template editor.

If you would like to see examples of the HTML files that Clarify generates when exporting to PDF, please refer to this article.

Select (or create) a custom template

Customize the CSS

1. Click on the Custom CSS tab.
2. Add the appropriate CSS to the field. For example:

```css
.step-container { }
```
This CSS tells the PDF generator to always add a page break after a step.

---

### Recipes

Here are a couple of recipes that change how PDF output looks.

#### Modify the style of the text in the document

You can add specific font styling to your PDF document by targeting specific CSS classes in the document. For example, to make step titles italic and bold you can do the following:

```
.step-title {
    font-style: italic;
    font-weight: lighter;
}
```

Here are some of the classes you can use to target content:

```
.article-description
.step-title
.sub-step
.step-instructions
```
If you wanted to target all of the document text try this:

```css
body, h1, h2, h3 {
  font-style: italic;
  font-weight: lighter;
}
```

Show the article title in the body of the document

By default the article title is hidden in the main body of the document as it is shown in the header. To show the article title use the following CSS:

```css
#content .article-title {
  display: inline;
}
```

Remove the header after page 1

Adjust the margin-top values to meet your needs.

```css
@page content {
  @top-left {
    content: "";
  }
  margin-top: 40pt;
}

@page content:first {
  @top-left {
    content: flow(header);
  }
  margin-top: 95pt;
}
```

Right-justify the header text

First set the Align Logo setting to Left.

```css
.header-text {
  text-align: right;
}
```
Set the maximum height for the logo in the header

```css
#header .logo {
    max-height: 25pt;
}
```

Remove spacing between paragraphs

```css
div > p:not(:last-child) {
    margin-bottom: 0px;
    margin-top: 0px;
}

div > p:last-child {
    margin-top: 0px;
}
```

Change spacing between list items

This CSS will change the spacing between all list items. It will not affect the spacing between the first list item and the preceding paragraph.

```css
li:nth-child(n+2) {
    margin-top: 2em;
}
```
Float images to the right of text

This CSS assumes a Letter page size with Landscape orientation. You would just need to adjust the max-width properties for other pages sizes/orientations. If you want to float the images to the left of the text just swap the "left" and "right" values in the CSS.

```
.step-instructions {
  float: left;
  width: 473pt;
}
.step-image-container {
  width: 250pt;
  float: right;
}
.step-container {
  clear: both;
}
```

Add a page break after every top-level step

If you want to break up each top-level step and it's substeps then use this CSS. This CSS will add page breaks before each top-level step. Use this CSS in combination with the Try to keep step content together content flow.

```
div.step-container:not(:first-child):not(.sub-step) {
  page-break-before: always;
}
```

Set a custom page size

This example sets the width of 21cm and height of 30cm with a landscape orientation.

```
@page {
  size: 21cm 30cm landscape;
}
```

Changing properties of paragraphs formatted as code

Code paragraphs are wrapped in <pre><code> tags.
Code runs are wrapped in `<code>` tags.

```html
pre code {
  ...
}
```

### Targeting the footer

The footer has a `footer` class applied to it.

```css
.footer {
  ...
}
```

You can target the footer text as well as the footer page number as well.

```css
.footer .page-number {
  ...
}

.footer-text {
  ...
}
```

### Change link color

```css
#content a {
  color: red;  
}
```
How does Clarify size images in PDF output?

When sizing images in PDF output, Clarify will assign different CSS classes to images based on the presence of the step title and instructions.

How Clarify assigns CSS classes to images

Here are the rules for applying image classes to images when exporting to PDF:

<table>
<thead>
<tr>
<th>Rule</th>
<th>Class</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step has title + instructions</td>
<td>img.small</td>
</tr>
<tr>
<td>Step only has title</td>
<td>img.large</td>
</tr>
<tr>
<td>Step only has instructions</td>
<td>img.medium</td>
</tr>
<tr>
<td>Otherwise</td>
<td>img.xlarge</td>
</tr>
</tbody>
</table>

Default Sizes

Clarify assigns values to each image class based on the size of the PDF page and the top and bottom margin. Clarify figures out what the working height is by subtracting the top and bottom margins from the page height. Here is the formula for each image class:

<table>
<thead>
<tr>
<th>Class</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>img.small</td>
<td>Working height * .90 - 160</td>
</tr>
<tr>
<td>img.medium</td>
<td>Working height * .90 - 80</td>
</tr>
<tr>
<td>img.large</td>
<td>Working height * .90 - 40</td>
</tr>
<tr>
<td>img.xlarge</td>
<td>Working height * .90</td>
</tr>
</tbody>
</table>

If the working height of the PDF page is 680 points then the following values would be assigned to the image classes:

```css
img.small { max-height: 452pt; }
img.medium { max-height: 532pt; }
img.large { max-height: 572pt; }
img.xlarge { max-height: 612pt; }
```

You can override these values in the Custom CSS tab of the PDF template editor.
Importing and Exporting Custom PDF Templates

You can share custom PDF templates that you create by exporting and importing PDF template files.

Open preferences

- On Mac: Clarify > Preferences
- On Windows: Edit > Preferences

Exporting a Template

Go into PDF Templates.

To export a PDF template, right-click on it and select Export Template from the contextual menu. You will be prompted to save the template to a file of your choosing. The resulting file will include the entire template in a single file.
Importing a Template

To import a template just right-click anywhere in the list of PDF Templates and select **Import Template**... from the contextual menu.
After selecting a PDF template file it will appear in your list of templates.
Miscellaneous
Installing a custom HTML template

This article will show you where to install a custom HTML template.

Reveal the custom template folder

From the Clarify Help menu, select Reveal Custom Template Folder.

The custom template folder

The custom template folder is where you install any custom templates that you want to add to Clarify. In this example I am on OS X so the folder is located in the user Application Support folder.

For HTML templates, you are interested in the HTML folder. Place the folder containing the custom template you want to install in the HTML folder. In this example I'm installing a custom template named Markdown.
Using your template

Once you relaunch Clarify, you can now use your template. For example, you can assign your template to a sharing account. Launch Clarify, select or create an HTML Sharing account, and choose your template from the HTML Template menu.

Your template will also be available from the File > Export menu.
Customizing the Copy Rich Text to Clipboard template

Clarify uses an HTML template to format the text that is copied to the clipboard when you select the Edit > Copy Document to Clipboard > Text and Images menu option. This article will show you how to customize the template that is used.

If you are not familiar with HTML templates then you should read the manual about HTML templates.

The HTML template used in this example can be downloaded below.

Locating the template folder

To add a template to Clarify use the Help > Reveal Custom Template Folder menu option to reveal the folder where you put templates.

The Clarify Templates folder will appear. It is located in the folder where user files are stored for applications.

The folder you are interested in is the Rich Text Clipboard folder. If an HTML template folder is placed in this folder, it will override the default HTML template that Clarify uses when copying a document to the clipboard.
Adding an HTML template folder

Here you can see that I have added an HTML template folder named **Custom Font**. The name is irrelevant as it won't show up anywhere.

**Important**: After installing an HTML template you need to restart Clarify in order for Clarify to use it.
Changing the font

This example changes the font of the text copied to the clipboard to Calibri. This is done by editing the @article.html file and adding some CSS.

```html
<html>
<head>
<title>?</title>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<style>
#Content {
  font-family: "Calibri";
  font-size: 11pt;
}
</style>
<body>
<div id="wrapper">
<div id="Content">
<?php print ArticleXHTML($article, 3, 'clarify-'); ?>
</div>
</div>
</body>
</html>
```

What the default clipboard template looks like

Here is what some text pasted into a word processing application looks like by default. Notice that the font is Times.
Using the new template

After installing the new HTML template in the Rich Text Clipboard folder the text that is copied to the clipboard uses the Calibri font.
Adding tags to your document

You can add tags to a Clarify document.

**Note:** Tags are exported to WordPress and Evernote. They can also be output in HTML, but it requires that you create a custom HTML template that handles them. There is no real need for tags in HTML in most cases.

Click on the article inspector
Add tags by typing in the tag field...
And clicking on the + icon
This Clarify document now has a tag

Auto Settings
- Auto-number Steps
- Auto scale images
  - Width: 600
  - Height:

Shared Locations
- https://ci.dropboxusercontent.com/spa/ngm3or...
  - Wednesday, July 23, 2014
Controlling how image ALT tags are generated when exporting to HTML

By default Clarify will only generate ALT tags for step images that you explicitly assign descriptions to. You can tell Clarify to auto-generate ALT tags, however.

Specifying an ALT tag for a step image

In the step inspector you can add an ALT text for the step image using the Image ALT Tag field.

Automatically generate ALT tags

If you would like Clarify to automatically generate ALT tags then go the Clarify preferences General tab and check the Automatically generate ALT tags checkbox. When checked, Clarify will use the step title to generate an ALT tag for step images. Of course, if you have specified ALT text using the step inspector then that text will be used.
Clarify Desktop
Moving Clarify to a different computer

Moving Templates and Annotation Presets

Reveal the Templates folder using the Help > Reveal Custom Template Folder menu option

From the **Help** menu, select **Reveal Custom Template Folder**.

![Help menu with Reveal Custom Template Folder selected]

In the Finder (OS X) or Windows Explorer (Windows) you will see the **Templates** folder revealed. At the same level as the **Templates** folder is an **Annotation Presets** folder. You want to copy these two folders to the new computer. **DO NOT** just copy the **2.0** folder.
Moving the Preference file on Windows

On Windows Vista and later the Clarify preference file is stored alongside the Annotation Presets and Templates folder. The file is named be Clarify Preferences.dat. Copy that file to the new computer as well.
Moving the Preference file on OS X

On OS X the Clarify preference file can be stored in two different locations. If you are running the version of Clarify available from our store then the file is located here:

```
~/Library/Preferences/com.bluemangolearningsystems.clarify-osx.plist
```

If you are running the version of Clarify purchased from the Mac App Store then it is located here:

```
~/Library/Containers/com.bluemangolearningsystems.clarify-osx/Data/Library/Preferences/com.bluemangolearningsystems.clarify-osx.plist
```

The ~ symbol represents your home folder on the computer.
Troubleshooting
Internet Issues

If you are experiencing issues with the internet connection between Clarify and a web server then it is helpful to create a log file to send to support.

Quit Clarify

1. Launch Clarify While Holding Down "Shift" Key

Immediately after launching Clarify press and hold the Shift key. Hold it down until you see a dialog window appear.

2. Click "Yes"

When the dialog appears, click Yes.

3. A Log File Is Created

A file named clarify_network_log.txt will appear on your Desktop. After you recreate the internet error within Clarify you can quit. Then send the clarify_network_log.txt file to us.
"Previous request not completed" error

If you are running Clarify on OS X and get the error "Previous request not completed" it may mean that you have your computer network set up with "Auto Proxy Discovery". At this time Clarify does not support automatic proxy detection on OS X. Turning the setting off allow Clarify to function properly.
Error when trying to capture on Windows: "An error occurred while capturing the screen: process is not open for write"

The Clarify 1 status menu helper is running

This error can occur if you have Clarify 1 installed and the Clarify 1 status menu helper is running in the system tray. Follow the instructions for turning it off.

Check that the shortcut key assigned to capture screenshots

Check to see if you've assigned the shortcut key to capture screenshots in Clarify to a key combination that is in use by another application on your computer. If you have, change the shortcut key. You may need to restart the computer.

Restart the Computer

Restarting the computer will fix this error in some situations.

Try Reinstalling

If you don't have the Clarify 1 status menu helper running then you can try reinstalling Clarify 2. This has resolved the issue for some users.
Why is the screen black when I try to capture the screen on Windows?

This issue is most likely caused by your anti-virus application. Anti-virus software, such as Webroot, will block applications from taking screenshots. The solution is to configure your security software to allow Clarify access to the screen.

Webroot

As of this writing, you can find instructions on changing the settings for an application in Webroot at the following URL:


You should change Clarify.exe from Deny to Protect or Allow.
Why does Clarify freeze when I try to capture the screen?

If Clarify appears to freeze when you try to capture the screen, check that you don't have another screen capture application running at the same time. If you trigger both screen capture applications at the same time Clarify can appear to freeze.
How do I troubleshoot "error 10013 on socket"?

When you configure a 3rd party service sharing account, like a Dropbox or Evernote, Clarify needs to authorize itself with the service. Clarify must temporarily acts as a web server in order to be notified that 3rd party service is allowing Clarify access. This is only done during when configuring the sharing account. It is not repeated each time you upload content to these services.

If you see the error "10013 on socket" during this process the most likely cause is that you have firewall software that is not allowing Clarify to act as a web server. You will need to configure you firewall to allow Clarify to do so in order to finish the authorization process.
Issues with posting to a WordPress blog

This article provides troubleshooting tips for known issues with posting to WordPress.

Note that these problems are all related to security issues associated with the xmlrpc.php file that ships with WordPress. We are currently working on a solution that uses a new JSON API for WordPress. It requires installing some plugins but so far in our tests does not experience any of the same issues. If you are having trouble posting to WordPress and would like to try the new solution we are working on then send an email to support@screensteps.com.

Error 403 Forbidden

If you have iThemes Security installed make sure you don't have it set to deny all xmlrpc.php files. Switch it to only deny pingbacks and try again.

"Unable to reach the Wordpress server", message about your IP address being banned, or a mod_sec.html error

Some web host providers will blacklist an IP address that makes multiple requests to the xmlrpc.php file in a WordPress installation. This is due to the fact that the file has historically been used for nefarious purposes. Since Clarify documents often contain multiple images it is making multiple requests to the xmlrpc.php file on your server and your web hosting service may flag you.

You can contact your hosting provider and ask them to whitelist you so that you can upload to WordPress.

Another potential cause of the "Unable to reach the WordPress server" error could be a WordPress plugin. At least one user has reported issues with using the "EWWW Image Optimizer" plugin. You can try disabling plugins to see if one is causing a problem.
Using Clarify with Wordpress.com Two-Step Authentication

Wordpress.com Two-Step Authentication Error messages

Error message when attempting to upload a blog entry

Next time you try to upload something from Clarify to Wordpress, you may encounter a message like this.
Go to Wordpress Settings Security page

2. Scroll down until you see the 'Application Passwords' headline.
3. Enter an Application Name, in this case 'Clarify'
4. Click the 'Generate Password' button
5. Copy the generated password and paste it into your Wordpress Settings in Clarify's preferences area.
Password Generated

Application Passwords

If you use one of our mobile apps or a third party service, you might need to use an Application Password to log in - you will receive an alert if this is required.

Once generated, return here to revoke access at any time.

Use this password to log in to foobar application. Note: spaces are ignored.

Copy new password to Clarify Wordpress Settings

t7ut zxyu gvqv 5rjc

Done
Unable to create a Dropbox or Evernote sharing account

If, after clicking the Allow button on the Dropbox or Evernote site, Clarify does not create the sharing account it may be because another application is listening on the same PORT on your computer (currently Clarify uses a port between 9990 and 9999).

We have had one report of Clarify not being able to finish creating an account if Extensis Portfolio is running. If you quit Extensis Portfolio you should be able to create the sharing account. After you have created the sharing account you can run Extensis Portfolio and Clarify together without any issues.
System compatibility issues

This article describes any known issues on platforms that Clarify supports.

OS X

1. The OS X version of the Clarify Capture Helper application (the app that handles screen capture) will sometimes cause a CPU spike. The current solution is to take a screenshot or restart Clarify. Doing so will calm things down. We are currently testing a fix for this and should have an update out soon.

2. No available font error, or errors about ssl certificates: Clarify 2.0.3 will produce errors if you change the name of the Clarify.app application name. For example, if you have changed it to Clarify 2.app. The solution is to rename the application back to Clarify.app. This bug will be fixed in the next update.

Yosemite (10.10)

No known issues (as of version 2.0.3).

Mavericks (10.9)

No known issues.

Mountain Lion (10.8)

No known issues.

Lion (10.7)

No known issues.

Windows
Windows 8.1
No known issues.

Windows 8
No known issues.

Windows 7
No known issues.
"the document could not be created" error when using Mac App Store version

If you see this error when trying to save anything you may have a permission issues in the application sandbox. The Console application may report that the sandbox is being denied "file-write-create" permissions.

Another error you might see is "can't open output file: No such file or directory" when trying to export to PDF or other formats.

Quit Clarify and delete the application sandbox

To fix this error delete the application sandbox:

```
~/Library/Containers/com.bluemangolearningsystems.clarify-osx
```

Note that this operation will delete any custom templates or annotation presets. Since this error occurs when you first start using Clarify this shouldn't be an issue. If it is then see our article on [where to locate the necessary files to backup](#).

Relaunch Clarify

The next time you launch Clarify the application sandbox will be recreated and you should no longer see this error.